FHWA HEPGIS HEPGIS  

HEPGIS Navigation Help

The HEPGIS website is an interactive, web-based geographic map server that enables users to navigate, view and print geo-spatial maps using only their web browser. Simple navigation tools allow users to locate and zoom-in to a geographic area of interest, and to create maps showing various geographic features and themes. The HEPGIS website also has tabular capabilities to retrieve, sort, print, download and email geo-spatial data. In addition to map and table functionalities, HEPGIS has unique matrix manipulation capabilities producing origin-destination desire line maps based on input from the interactive user interface. The HEPGIS website is designed to work on all desktop browsers.


HEPGIS Application


Click on a HELP topic below to navigate to the selected section.


Map Menus

Navigation Tools

Initial Scale

Previous Scale

Zoom In

Zoom Out

Pan

Info Tool

Slider Scale

Application Tools

Find Map

Find Location

Find Points of Interest

Print Map

Print Table

Download Table

Email Page

Accessible Version

Download Data

Legend Window Tabs

Sources

Legend

Data

Layers

FAF4 Origin-Destination Flow Maps

Border Commodity Flow Maps

Flows Through US Ports of Entry

Flows From/To US FAF4 Zones


Map Menus


There are over 70 interactive maps on the HEPGIS website. The maps are organized under six categories/dropdown menus located in the “Map Menus” strip below the FHWA header. The categories are Highway System, Fatal Crashes, MPO Information, Demographic Maps, Megaregion Research and Freight Analysis (FAF4).


Map Menus


  1. Click on a dropdown menu, such as “Highway System” to display a list of highway related maps.

  2. Click on a map name in the dropdown menu in order to display the map in the map window.

Navigation Tools


You change the map scale and center using tools on the top left side of the map window.

Tool

Name

How to Use It

InitialMap.png

Initial Map Scale

Click the button to return to the initial map scale.

PreviousScale1.gif

Previous Scale

Click the button to return to the previous scale

aazmin1.gif

Zoom In

Click on a point, or drag a rectangle, to make the scale larger and change the center

aazmout1.gif

Zoom Out

Click on a point, or drag a rectangle, to make the scale smaller and change the center

AAPAN1.GIF

Pan

Drag the map to change the center

aaInfo2.gif

Info Tool

Click on a location to get information about that location.


You can also use the vertical slider to change the scale from large scale, at the top, to small scale, at the bottom or use the "Find Location" option to zoom to a particular region, state, MPO, or city/town.

To Return a Map to the Initial Map Extent

  1. Click InitialMap.gif on the left side of the map window.

The web application draws the map with the extent that was used when the map was first opened which displays the whole United States.

To Return a Map to the Previous Scale and Center

  1. Click PreviousScale1.gif on the left side of the map window.

The web application draws the map with the extent that was used before the most recent change. You can repeat this step to continue to retrace each change all the way back to the extent that was used when the map was first opened.

To Zoom In on a Map (Make the Scale Larger)

  1. Click aazmin1.gif on the left side of the map window to activate the Zoom In tool.

  2. Click on a location to double the size or drag a rectangle around the part of the map you want to see enlarged.

The web application redraws the map at the new scale.

To Zoom Out on a Map (Make the Scale Smaller)

  1. Click aazmout1.gif on the left side of the map window to activate the Zoom Out tool.

  2. Click on a location to halve the size or drag a rectangle around the part of the map into which you want to reduce the current map.

If you dragged a rectangle, the web application redraws the map so that the current map area is reduced to fit into the rectangle. The smaller the rectangle is, the more the map will be zoomed out and the smaller the scale will be. If the rectangle is off to one side of the map, more features will be displayed on the other side of the map.

Pan - To Change the Center of the Map

  1. Click AAPAN1.GIF on the left side of the map window to activate the Pan tool.

  2. Position the cursor anywhere on the map and hold down the mouse button.

  3. Drag the map to a new location and release the mouse button.

The location becomes the new map center.

Info Tool - To Get Location Information

  1. Click aaInfo2.gif on the left side of the map window.

  2. Position the cursor anywhere on the map and click to get information about a location.

The web application opens a pop-up window displaying information about the map location. In some maps, information is available for several different map layers. Choose a tab at the top of the pop-up window to see data for a particular layer.

To Change the Scale with the Slider

  1. Click and drag the box, or click inside the slider that is on the left side of the map window.

The web application redraws the map at the new scale, and shows the percent relative to the scale of the whole state below the slider.

Application Tools


The “Application Tool” strip is located below the “Map Menus”.

Application Tools


Find Map


Map Menus


  1. Type a few words to get a list of matching map names.

  2. Select a map from the list and then click the “Draw Map” button.

Find Location


Find Location


  1. Click "Find Location" button to display a pop-up window for finding locations.

  2. Choose whether to find a region, state, MPO, or city/town.

  3. Choose region, state, or MPO from the dropdown list, or enter a city/town name and choose the state.

  4. Click the "Find" button in the pop-up window.

The location becomes the new map center. Click the Close (X) button at the top-right of the pop-up window to close it.

Find Points of Interest


Points of Interest


  1. Click the “Find Points of Interest” button.

  2. Type the address of the area of interest.

  3. Choose the search radius around the address and the points of interest to be located within the radius.

  4. Click the “Find” button.

The “Area of Interest” map will be displayed in the “Map Window” with the given address as the map center and the points of interest displayed within the chosen radius of the address.

Print Map


Click the “Print Map” button to print an image of the map displayed in the “Map Window”.

Print Table


Click the “Print Table” button to print the selected table.

Download Table


Click the “Download Table” button to download the selected table to an EXCEL spreadsheet. A table must first be opened using the “Data” Tab on the “Legend Window”.

Email Page


  1. Click the “Email Page” button.

  2. Fill in the requested information and click “Send Message”.

An email will be sent to the recipient which includes attachments of the map and legend displayed.

Accessible Version


Click on the “Accessible Version” button and an accessible version of the website will be displayed.

Download Data


Download Data


  1. Click the “Download Data” button to open a window with the list of files available for downloading.

  2. Click on a file in the list to download. A new request window will open.

  3. Type the required information in the appropriate boxes: work email, name, company, and how you plan to use the data. Choose the search radius around the address and the points of interest to be located within the radius.

  4. Click the “OK” button and an email with the link to the download data will be sent to your email address.

Legend Window Tabs


The "Legend Window" is located to the right of the "Map Window".

Sources Tab


The “Sources” tab displays the source of the primary map layer in the map that is currently displayed in the “Map Window”. The date the map was updated, as well as contact information is also listed.

Legend Tab


The “Legend” tab displays the legend of the map layers currently displayed on the map.

Data Tab


  1. In the “Legend Window”, click the "Data" tab.

  2. Click on one of the available data layers. The web application opens a pop-up window displaying a table with the data for the chosen layer. You can refine the table by sorting and filtering the records as described below.

To Sort and Filter the Columns in a Table

  • To sort the table, click on a column heading. The table is sorted in increasing order by the values in the chosen column. Click the heading again to sort in decreasing order.
  • To choose the fields that are displayed, choose "Show/Hide Columns..." to display a pop-up window with the hidden and visible fields columns. Choose fields from either list and click the appropriate arrow button (<---- or ---->) to move fields from one list to the other.
  • To change the order of the columns, click and drag a column heading left or right. Release the mouse button when the column is where you want it.
  • To filter the fields that are displayed, type a value in the text item under a header and then choose the filter to apply (e.g. Equals, Starts With, Contains...). You can further filter the results by choosing additional fields and entering other filters.

    To remove all filters, click on the arrow item in a header and choose "No Filter".

Layers Tab


The “Layers” tab lists layers that can be turned on/off on the map.

  1. Click the check boxes of the layers and/or layer labels that you would like turned on and displayed on the map.

  2. To turn off a layer, uncheck the box.

  3. Click the “Redraw Map” button and the map will refresh with your selections.

Drawing FAF4 Origin-Destination Flow Maps


To access the FAF4 flow map menus, click on the “Border Flows / FAF4” map dropdown menu, “FAF4 Origin-Destination Flows” and select one of the three flow choices – “Flows by FAF4 Zones”, “Flows by Metro Regions”, or “Flows by States”. The three choices have similar menus selections. Below is an example of "Flows by States".

FAF4 Menus



Flows by States


After selecting "Flows by States", the “Flow Map by State” menu is displayed. There are five tabs at the top of this menu: Map Type, Commodity, Origin, Destination and Minimum.


FAF4 Menu


  1. The first tab is “Map Type”. Choose a selection from each dropdown menu displayed: Type/Country, Year, Scenario, Unit and Domestic Mode.

  2. Click on the next tab, "Commodity" and select a commodity from the list.

  3. Click on the tab, "Origins" and select one or more "Available" States from the left box. These are the States which are the origins of the commodity to flow. Click the arrow in the middle to copy the selected States to the "Selected Origins" box on the right.

  4. Click on the tab, "Destinations" and complete the same type of selection as for the "Origins" tab. These selected States are the destination regions of the commodity flow. It is also possible to click the "Same as Origins" button to select the same States as selected for origins.

  5. Click on the tab, "Minimum" and if desired, enter a value in the box. No flows below this value will be drawn on the map, but will be listed in the table.

  6. Note that on the bottom of the menu box is a description of the selected parameters. Next click on the "Create Map" button in the lower right corner of the menu. A map will be drawn based on the user's selections and a table will open with the values of each origin-destination flow.

State Flow Map


Drawing Border Commodity Flow Maps


To access the border flow map menus, click on the “Border Flows / FAF4” map dropdown menu, “Border Commodity Flows” and select one of the two flow choices – “Flows Through US Ports of Entry”, “Flows From/To US FAF4 Zones”.

Border Flow Menus



The geography of the Border Flow map displays North America countries, including 13 Canadian provinces, 32 Mexican states, 132 US FAF4 zones, and 110 border crossings.

Border Flow Menus



Flows Through US Ports of Entry


"Flows Through US Ports of Entry" allows the user to create flow maps showing different commodities import/export flows from one or more ports to all origins and destinations. To create a flow, after selecting “Flows Through US Ports of Entry”, the “Flow Map by Border Crossing” menu is displayed. There are four tabs at the top of this menu: Map Type, Commodity, Thru Port, and Minimum.


Border Crossing Menu


  1. The first tab is “Map Type”. Choose a section from each dropdown menu displayed: Type/Country, Year, Scenario, Unit and Domestic Mode.


  2. Click on the next tab, "Commodity" and select a commodity from the list. There are 43 commodity groups, the same as the groups used in FAF4.

  3. Border Flow Commodity Menu


  4. Click on the tab "Thru Port" and select one or more "Available" Thru Ports from the left box. These are the 110 border crossing (ports) through which the commodity is imported and exported. Click the arrow in the middle to copy the selected available ports to the "Selected Thru Port" box on the right. Below the "Available" box is a "Filter" box. Type the abbreviation of a port or other name to get a list of only the port with the filter.

  5. Border Flow Thru Port Menu


  6. Click on the tab, "Minimum" and if desired, enter a value in the box. No flows below this value will be drawn on the map, but will be listed in the table.

  7. Border Flow Min menu


  8. Note that on the bottom of the menu box is a description of the selected parameters. Next click on the "Create Map" button in the lower right corner of the menu. A map will be drawn based on the user's selections and the map summary statistics will be displayed on the Legend Window on the right. If a user wants to show only imports or exports, click on the "Layer" tab on the "Legend Window" to turn off either the Import or Export layer.

  9. Border Flow Thru Port Map

  10. Click on any Origin or Destination on the map. Summary statistics will be displayed in a white box and a user can also draw a flow map from that location by clicking on the "Draw Flows From/To This Zone".

  11. Border Flow Thru Port Map

  12. To View the Data associated with the Import/Export flows, click on the 'Data' tab on the 'Legend Window". Select either "US Import Flows" or "US Export Flows". The Data View window will open displaying with the corresponding flow data. Go to the Legend Window Data Tab help to learn how to sort and filter the columns in a table.

  13. Border Flow Map Data


Below is another flow map with more than one thru ports on the southern border.

Border Flow Map Data

Flows From/To US FAF4 Zones


"Flows Through US Port of Entry" are designed for displaying commodities transported via specific border crossings regardless of origins and destinations. If a user wants to know specific flow volumes between certain origins and destinations, click on “Flows From/To US FAF4 Zones” and the “Flow Map by Country” user interface is displayed. There are five tabs: Map Type, Commodity, From Pr/St., To FAF Reg., and Minimum.


Flow by Country Menu


  1. The first tab is “Map Type”. Choose a section from each dropdown menu displayed: Type/Country, Year, Scenario, Unit and Domestic Mode.

  2. Click on the next tab, "Commodity" and select a commodity from the list.

  3. Click on the tab "From Pr/St." and select one or more "Available" Canadian Province/Mexican States from the left box. Click the arrow in the middle to copy the selected available Province/States to the "Selected From Pr/St." box on the right. Below the "Available" box is a "Filter" box. Type the abbreviation of a State or other name to get a list of only the Pr/St. with the filter.

  4. Border Flow From Point Menu


  5. Click on the tab "To FAF Reg." and select one or more "Available" FAF Regions from the left box. These are 132 FAF4 zones. Click the arrow in the middle to copy the selected available FAF4 zones to the "Selected to FAF Reg." box on the right. Below the "Available" box is a "Filter" box. Type the abbreviation of a State or other name to get a list of FAF regions with the filter.

  6. Click on the tab, "Minimum" and if desired, enter a value in the box. No flows below this value will be drawn on the map, but will be listed in the table.

  7. Note that on the bottom of the menu box is a description of the selected parameters. Next click on the "Create Map" button in the lower right corner of the menu. A map will be drawn based on the user's selections and the map summary statistics are shown on the "Legend Window" on the right.

  8. Border FAF Regions Map



  9. To View the Data associated with the origin-destination flows, click on the "Data" tab on the "Legend Window". Select the data type (ex: "US Import Flows). The Data View window will open displaying with the corresponding flow data. Go to the Legend Window Data Tab help to learn how to sort and filter the columns in a table.

  10. Border Flow Map Data